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1 Overview 

 Taking N32H760 series MCU as an example, this paper introduces the methods of setting up 

development environment, It is applicable to all N32 MCU series.. 

2 Development tools 

 software 

1) Operating System: WIN7 / WIN10 64-bit OS  

2) IDE: Eclipse IDE for GNU ARM & RISC-V C/C++ Developers  

3) Cross Compiler Toolchain: arm-none-eabi-gcc  

4) Build Tools: GNU MCU Eclipse build tools  

5) GDB Server: J-Link GDB Server  

6) Debugger: J-Link V9/V10 

 

 hardware 

1) Development board N32H760xIx7-STB V1.0 

2) JLink Downloader V9 (need to be no lower than the software support version) or above 
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3 Development environment setup 

 Installing the ARM Cross Compiler Toolchain 

 Download the file xpack-arm-none-eabi-gcc-10.2.1-1.1-win32-x64.zip: 

Download Address: https://github.com/xpack-dev-tools/arm-none-eabi-gcc-xpack/tags 

You can visit https://github.com/xpack-dev-tools/arm-none-eabi-gcc-xpack/releases/ to select and download other 

different versions of the ARM Cross Compiler Toolchain. 

 Installing Build Tools 

 Download the file xpack-windows-build-tools-4.2.1-2-win32-x64.zip: 

Download Address: https://github.com/xpack-dev-tools/windows-build-tools-xpack/releases/tag/v4.2.1-2/  

You can visit https://xpack.github.io/windows-build-tools/releases/ to select and download different versions of the 

build tools. 

  

https://github.com/xpack-dev-tools/arm-none-eabi-gcc-xpack/tags
https://github.com/xpack-dev-tools/arm-none-eabi-gcc-xpack/releases/
https://github.com/xpack-dev-tools/windows-build-tools-xpack/releases/tag/v4.2.1-2/
https://xpack.github.io/windows-build-tools/releases/
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 Installing Eclipse IDE 

3.3.1 Installing JDK 

 Download the file jdk-8u202-windows-x64.exe: 

Eclipse requires a Java environment to run, so JDK must be installed prior to installing Eclipse.  

You can visit http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html to 

select and download different versions of the JDK tools. 

In this document, jdk-8u202-windows-x64.exe is selected for download and installation. After the installation of the 

file jdk-8u202-windows-x64.exe is completed: 

Verify the installation: Open a DOS command prompt window and type java -version to test if the JDK is installed 

correctly. If the JDK is installed properly, you will get output similar to the one shown in the figure. 

 

 

3.3.2 Installation of Eclipse IDE for GNU ARM C/C++ Developers 

 Download the file eclipse-embedcpp-2021-03-R-win32-x86_64.zip 

Download Address: 

https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/2021-03/R/eclipse-

embedcpp-2021-03-R-win32-x86_64.zip 

You can visit https://eclipse-embed-cdt.github.io/packages/releases/ to select and download different versions of the 

Eclipse IDE. 

  

http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html
https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/2021-03/R/eclipse-embedcpp-2021-03-R-win32-x86_64.zip
https://www.eclipse.org/downloads/download.php?file=/technology/epp/downloads/release/2021-03/R/eclipse-embedcpp-2021-03-R-win32-x86_64.zip
https://eclipse-embed-cdt.github.io/packages/releases/
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 Installing the JLink Tool 

 Download the JLINK installation package, V7.50 or others version 

Download Address: https://www.segger.com/downloads/jlink/#-LinkSoftwareAndDocumentationPack 

 

 Adding Chip Support 

After installing JLink, we need to add our company's chip patch package to JLink, so that we can get 

the download algorithm correctly during downloading and debugging. 

For details, see <jlink Tool Adding Nations Chip.7z>. 

 JLink download test 

 Test the JLink environment installation 

1，Connect the PC and j-Link debugger, connect the development board, and power on; 

2，Open cmd.exe command line tool, go to JLink installation directory C:\Program Files 

(x86)\SEGGER\JLink_V640, type jlink.exe. 

https://www.segger.com/downloads/jlink/#-LinkSoftwareAndDocumentationPack
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The image above shows that the PC successfully connected to the JLink debugger. 

3，Then according to the prompt input: “connect”, “N32H760XIX7”, “SWD”, “4000”, if the 

previous operation is successful, you will see the following output information, JLink 

download debugging environment can be used normally. 
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4 Eclipse Launch and Configuration 

 4.1 Create a New Workspace 

Eclipse is a portable application that requires no installation. Simply double-click eclipse.exe in the Eclipse folder to 

launch the program. The interface after launch is shown in the figure below. 

 

As shown in the figure below, select a local path without Chinese characters, create a workspace, and click Launch. 

Note that the path depth should not be too great.  

After entering the welcome page, you can either close the Welcome tab in the upper left corner directly or click the 

Workbench icon in the upper right corner to enter the main interface. 
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 Set the Path of Build Tools 

In the Eclipse installation directory, create a folder named Eclipse_toolchain. Decompress both the ARM cross-

compilation toolchain and Build tools downloaded according to the tool installation instructions, and place them 

into this folder, as shown in the figure below. 

 

1) Open the Window > Preferences option 

 

2) Select MCU > Global Build Tools Path, and set the global Build Tools path: 

${eclipse_home}\eclipse_toolchain\xpack-windows-build-tools-4.2.1-2\bin. A relative path is required here 

for configuration. 
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 Set the Cross-Compilation Toolchain Path 

Select MCU > Global Arm Toolchains Path, and set the global Arm Toolchains path: 

${eclipse_home}\eclipse_toolchain\xpack-arm-none-eabi-gcc-10.2.1-1.1\bin 
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 Set the SEGGER J-Link Path 

Select MCU > Global SEGGER J-Link Path, and set the global SEGGER J-Link tool path. Select a local absolute 

path here, and the path in this example is C:\Program Files\SEGGER\JLink75. 

 

This completes all configurations for the Eclipse IDE. 
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5 Project Creation and Configuration 

The SDK uses the released newest version, with v1.0.0 being the current version. Based on this version, make the 

following modifications to adapt to the Eclipse development environment. 

 Create a New Project 

1) Open Eclipse, navigate to File > New, select C/C++ Project, and then choose C Managed Build. 

 

2) Select C Managed Build 

 

3) Enter the Project name, configure the project type, and it is recommended to place the project in the Workspace 
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directory for convenience. Select ARM Cross GCC as the compilation toolchain. 

 

4) If the ARM Toolchains Path has been correctly configured in Eclipse IDE, the path will be selected 

automatically here. If the ARM Toolchains Path has not been configured in Eclipse IDE, you can also select 

the absolute path of the ARM Toolchains manually here. Then click Finish to complete the project creation. 
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 Folder Creation and File Import 

1) Right-click the project name and select New > Folder.  

 

2) Create sub-virtual folders named STARTUP, BSP, CMSIS, DOC, FWIB, LD, SVD, and USER respectively.  

 

3) Right-click BSP and select the Import option to import files into the BSP folder. Similarly, the import method 

for other folders is the same, and redundant descriptions are omitted here.  
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4) After the import is completed, the file structure is shown in the figure below. 
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 Project Configuration 

5.3.1 Chip Selection 

Right-click the project and select the Properties option to open the project properties. Under C/C++ Build > 

Settings > Tool Settings > Target Processor, configure as follows: select cortex-m3, cortex-m4, cortex-m0 or 

cortex-m7 according to the core of the target chip. In this example, cortex-m7 is selected, as shown in the figure 

below. 

 

5.3.2 Optimization Level Configuration 

In the C/C++ Build > Settings > Tool Settings > Optimization option, configure the optimization level. The 

available options are -O0, -O1, -O2, -O3, -Os, -Ofast, and -Og. 
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5.3.3 GNU Arm Cross C Compiler Macro Configuration 

In the C/C++ Build > Settings > Tool Settings > GNU Arm Cross C Compiler option, configure the Cross C 

Compiler options. 

In this example, add the precompilation macros CORE_CM7, N32H76x and USE_STDPERIPH_DRIVER in the 

Preprocessor > Defined symbols (-D) option. 
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在”includes->Include paths”选项中添加工程所需的头文件路径。在本例中添加： 

5.3.4 GNU Arm Cross C Linker Configuration 

Configure the Cross C Linker options in C/C++ Build > Settings > Tool Settings > GNU Arm Cross C Linker. 

Add the following content in the General > Script files option: 

"${workspace_loc:/${ProjName}/LD/n32h76x_78x_flash.ld}" 

 

The linker script is responsible for telling the linker how to configure the memory for the compiled executable file. 

The linker script used shall match the FLASH and SRAM sizes of the target chip as well as the memory configuration 

required by the customer. 

Note: Uncheck the option "Do not use standard start files". 

In the Miscellaneous option, check the boxes for Use newlib-nano and Do not use syscalls. (This optimizes the 

code size.) 

"${ProjDirPath}/../../../../../../firmware/n32h76x_78x_std_periph_driver/inc" 

"${ProjDirPath}/../../../../../../firmware/CMSIS/core" 

"${ProjDirPath}/../../../../../../firmware/CMSIS/device" 

"${ProjDirPath}/../../../../bsp/inc" 

"${ProjDirPath}/../inc" 
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5.3.5 Configure Bin File Generation 

Commands can be added in C/C++ Build > Settings > Build Steps to generate bin/hex files. 

In this example, add the following commands: 

arm-none-eabi-objcopy -O binary "Project.elf" "Project.bin"; arm-none-eabi-objdump -D "Project.elf" > 

"Project.dump" 
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6 Compilation 

Select Project > Build Project to compile the current project. Save the current project before each compilation; 

otherwise, the previous version of the project will be compiled instead. After making modifications, to ensure 

correctness, please clean the project first before building it. Upon compilation completion, the corresponding elf, 

hex, and bin files will be generated. 
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7 J-Link Download and Debugging 

Click Run > Debug Configurations in the menu bar to open the Debug configuration interface. Select J-Link GDB 

Server CL as the GDB Server, and use the GDB tool in the GCC toolchain as the GDB Client. Double-click GDB 

SEGGER J-Link Debugging to create a new set of J-Link configuration options. 

 Main Tab 

In the Main tab, select the current project. Normally, the elf file under the current project will be added automatically. 

If not, click Browse to manually add the elf file. 

 

 Debugger Tab 

In the Debugger tab, fill in the Device name of the target chip, which is N32H760xIx7 in this example. 

If the J-Link path was configured correctly during the Eclipse environment setup, it will be recognized automatically 

here. If it was not configured correctly previously, you can also select the absolute path of J-Link GDB Server CL 

in the Executable path field. 

Note: The filled-in chip model must be supported by the configured J-Link driver. 
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 SVD Path Tab 

In the SVD Path tab, select the SVD file required by the target chip. 
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 Debug Interface 

After the J-Link is connected to the device and the Debug Configurations are configured, click Debug to enter the 

Debug perspective, then switch to the DEBUG perspective to start normal debugging. 
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8 Import Existing Projects 

1) Besides creating a new project, you can also directly import an existing Eclipse project. In the menu bar, click 

File > Import and select General > Existing Projects into Workspace to import the existing project, then click 

Next. 

 

2) Select the path of the existing project files. Eclipse will recognize all projects under this path. Select the 

corresponding project and click Finish to import the existing project. 
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9 Version history 

Date Version Modify 

2025/10/21 V1.0.0 The initial release 
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10 Notice 

This document is the exclusive property of NSING TECHNOLOGIES PTE. LTD. (Hereinafter referred to as NSING). 

This document, and the product of NSING described herein (Hereinafter referred to as the Product) are owned by 

NSING under the laws and treaties of Republic of Singapore and other applicable jurisdictions worldwide. The 

intellectual properties of the product belong to NSING Technologies Inc. and NSING Technologies Inc. does not 

grant any third party any license under its patents, copyrights, trademarks, or other intellectual property rights. Names 

and brands of third party may be mentioned or referred thereto (if any) for identification purposes only. NSING 

reserves the right to make changes, corrections. enhancements, modifications, and improvements to this document at 

any time without notice. Please contact NSING and obtain the latest version of this document before placing orders. 

Although NSING has attempted to provide accurate and reliable information, NSING assumes no responsibility for 

the accuracy and reliability of this document. It is the responsibility of the user of this document to properly design, 

program, and test the functionality and safety of any application made of this information and any resulting product. 

In no event shall NSING be liable for any direct, indirect, incidental, special, exemplary, or consequential damages 

arising in any way out of the use of this document or the Product. NSING Products are neither intended nor warranted 

for usage in systems or equipment, any malfunction or failure of which may cause loss of human life, bodily injury 

or severe property damage. Such applications are deemed, Insecure Usage’. Insecure usage includes, but is not limited 

to: equipment for surgical implementation, atomic energy control instruments, airplane or spaceship instruments, all 

types of safety devices, and other applications intended to supporter sustain life. All Insecure Usage shall be made at 

user's risk. User shall indemnify NSING and hold NSING harmless from and against all claims, costs, damages, and 

other liabilities, arising from or related to any customer's Insecure Usage Any express or implied warranty with regard 

to this document or the Product, including, but not limited to. The warranties of merchantability, fitness for a 

particular purpose and non-infringement are disclaimed to the fullest extent permitted by law. Unless otherwise 

explicitly permitted by NSING, anyone may not use, duplicate, modify, transcribe or otherwise distribute this 

document for any purposes, in whole or in part.  
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